Tapping noise form engine bay

Results 1 to 5 of 5
  1. #1
    *Newbie*
    Join Date
    Mar 2016
    Location
    Mansfield
    Posts
    27
    Dislike / Like Alerts

    Tapping noise form engine bay

    Ive posted one FB about this but ppl just come up with some random stuff that made no sense apart of one hydraulic lifters.
    Maybe someone on here might know the cause of the issue i am having

    So the tapping noise i am having been there for two days now and it's like when i start the mg in morning to warm up the engine ect the temp. goes to where it should be and then the tapping start's.It's not dead loud but y can hear it by the time i get to work it's gone.The weird thing is after my shift that's 8 hours parked in car park i start the car and it's fine no tapping but it comes back in the morning.It doesnt tapp when it's cold just start doding it when it get's to the right temp. The oil and filter been doen like 6-7 month's ago done about 2000/2500 miles since have done the wayne's lifter treatment ect.Everyone were bragin about the oil change ect of fb but i dont think that's the case this time.
    It's mg zr 1.4 never rev. over 3 k when cold and do care about it like my own kid.
    Hope anyone can help me out with this one .

  2. Likesrjhoy02 liked this post
  3. Remove Advertisements
    MGZR Owners Club
    Advertisements
     

  4. #2
    Senior Member
    Join Date
    Aug 2013
    Location
    Bedford
    Posts
    999
    Dislike / Like Alerts
    What grade of oil did it have out of interest does sound like a possible lifter problem

  5. #3
    *Newbie*
    Join Date
    Mar 2016
    Location
    Mansfield
    Posts
    27
    Dislike / Like Alerts
    Quote Originally Posted by JOHNDQ View Post
    What grade of oil did it have out of interest does sound like a possible lifter problem
    ive had 10w40 magnatech
    Ok so after visiting the garage the lads advised me to change the oil first,fair enough went back next day they done proper drain/treatment ect but instead of 10w40 they filled mines up with 5w30.Now even though ive only doen like 2000/2500 miles since the last oil change the oil was black.

    Now the next day and day after the tapping was still there but dead quite .... now it seems to be gone,the only thing i cant understand what made the oil to disintegrate so quickly ? the oil should last longer then 2000/2500 miles or am i wrong ?
    Last edited by isq0; 12-07-16 at 08:25.

  6. Likesrjhoy02 liked this post
  7. Remove Advertisements
    MGZR Owners Club
    Advertisements
     

  8. #4
    Senior Member
    Join Date
    Aug 2013
    Location
    Bedford
    Posts
    999
    Dislike / Like Alerts
    The oil should be be ok for about 10k if its good quality but very its not been changed by other owners etc that wont help. Ive been doing my ZS every 1000 miles with 5w40 fully synthetic as its clearly had a lack of changes and its only just started coming oil cleanish after 4 or so goes. Must say not heard of anyone using 5w30 might be a bit thin when it gets hot i would replace it with 10w40 or 5w40 after 1000 miles if you can

  9. Likesrjhoy02 liked this post
  10. #5
    *Newbie*
    Join Date
    Mar 2016
    Location
    Mansfield
    Posts
    27
    Dislike / Like Alerts
    Quote Originally Posted by JOHNDQ View Post
    The oil should be be ok for about 10k if its good quality but very its not been changed by other owners etc that wont help. Ive been doing my ZS every 1000 miles with 5w40 fully synthetic as its clearly had a lack of changes and its only just started coming oil cleanish after 4 or so goes. Must say not heard of anyone using 5w30 might be a bit thin when it gets hot i would replace it with 10w40 or 5w40 after 1000 miles if you can
    hmm i see ... then ive got 2 more to do then,well yeah after a while ill just do a full service then

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Image resizer by SevenSkins
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © MGZROwnersClub.co.uk
All times are GMT +1. The time now is 12:13.