clutch high

Results 1 to 10 of 12

Thread: clutch high

\r\n
\r\n
\r\n
\r\n \r\n
\r\n whitetop\r\n \r\n
whitetop is offline\r\n\r\n \r\n
\r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
\r\n
\r\n
Join Date
Aug 2016
\r\n \r\n \r\n
Posts
58
\r\n
\r\n\r\n
\r\n
Dislike / Like Alerts
\r\n
\r\n\r\n
\r\n\r\n
\r\n \r\n \r\n \r\n \r\n
\r\n
\r\n
\r\n \r\n \r\n

\r\n high clutch\r\n

\r\n \r\n\r\n\r\n \r\n \r\n
\r\n
\r\n
\r\n Hi guys not sure this was answered.
\r\n
\r\nI got my zr on the road (105/1.4L) and i\'ve found that the clutch peddle is really high, how can one sort this out? i read many things but don\'t want to piss about with the clutch really. its made me cut out 3 times now and in heavy traffic as its so high and when i put the pedal down to change gear to move off its like its not clicking in unless i rev high to move the car (not liking it).
\r\n
\r\nwhile its driving it seems ok going through gears, its just its like its not biting when pulling off and the lightness of the pedal. (t was ok till i got it from the MOT place in September\r\n
\r\n
\r\n\r\n \r\n
\r\n
\r\n \r\n
\r\n \r\n \r\n
\r\n \r\n Last edited by whitetop; 03-04-17 at 13:43.\r\n \r\n \r\n
\r\n \r\n \r\n \r\n \r\n \r\n \r\n
\r\n \r\n
\r\n
\r\n
\r\n
\r\n -' + '->\r\n
\r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
\r\n
\r\n
\r\n\r\n'; pd[158778] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #2\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n JOHNDQ\r\n \r\n
    JOHNDQ is offline\r\n\r\n \r\n
    \r\n \r\n Senior Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n \r\n JOHNDQ\'s Avatar\r\n \r\n
    \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2013
    \r\n
    Location
    Bedford
    \r\n \r\n
    Posts
    994
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Do you mean the pedal sits really high in the car or the biting point is really high\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158794] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #3\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n whitetop\r\n \r\n
    whitetop is offline\r\n\r\n \r\n
    \r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2016
    \r\n \r\n \r\n
    Posts
    58
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Prity much both, the pedal is high and when pressed you can feel all the loose part that should not be that loose.
    \n
    \nThe biting part feels the same, i got to high rev for it to move and to make sure its pulling off right (feel like a **** doing it to such a nice car)\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158834] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #4\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n JOHNDQ\r\n \r\n
    JOHNDQ is offline\r\n\r\n \r\n
    \r\n \r\n Senior Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n \r\n JOHNDQ\'s Avatar\r\n \r\n
    \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2013
    \r\n
    Location
    Bedford
    \r\n \r\n
    Posts
    994
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Sure the cable is ok all the self adjusting is done internally. Is it a MK1 the clutch pedal is higher on those anyway\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158865] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #5\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n whitetop\r\n \r\n
    whitetop is offline\r\n\r\n \r\n
    \r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2016
    \r\n \r\n \r\n
    Posts
    58
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Its a MK2, its becoming a real problem since driving it, cutting out and having no real control of the clutch, (i got a feeling the thing would need changing soon the way its going)
    \n
    \nwent out today to pick son up from school and the black cable to the battery was loose some how, now i got a flat battery some how as well, i\'ve driven over 40 miles since saturday so am thinking the alarm is draining the battery/dash cam or he alternator i crap, got a spare from the facebook group but never used it and not sure its still good.\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158953] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #6\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n whitetop\r\n \r\n
    whitetop is offline\r\n\r\n \r\n
    \r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2016
    \r\n \r\n \r\n
    Posts
    58
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Oh well looks like my alternator has gone, ffs, love the mg\'s but after this car its my second and very last rover i\'m ever going to have, dam thing just suck money with all the dam problems, plus found out i\'ve got OEM bmw parts in my car, how i do not know and a ford item plugged into my gear box?\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158961] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #7\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n JOHNDQ\r\n \r\n
    JOHNDQ is offline\r\n\r\n \r\n
    \r\n \r\n Senior Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n \r\n JOHNDQ\'s Avatar\r\n \r\n
    \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2013
    \r\n
    Location
    Bedford
    \r\n \r\n
    Posts
    994
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n If you got the IB5 gearbox its made by ford used in Escorts and Fiestas. Alternator should be a cheap fix tho\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158969] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #8\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n whitetop\r\n \r\n
    whitetop is offline\r\n\r\n \r\n
    \r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2016
    \r\n \r\n \r\n
    Posts
    58
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Not sure, its a 2004 (end of year) facelife, says plus on the log book (my bros mk2 never had plus on his!
    \n
    \nGot it changed at the place i got my MOT, 40$ to check the wiring and change belt and alternator and said it working great not, hope it does as its costing a bomb to sort this car out.\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[158977] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #9\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n JOHNDQ\r\n \r\n
    JOHNDQ is offline\r\n\r\n \r\n
    \r\n \r\n Senior Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n \r\n JOHNDQ\'s Avatar\r\n \r\n
    \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2013
    \r\n
    Location
    Bedford
    \r\n \r\n
    Posts
    994
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Trouble with these cars now there old and things will start to play up\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[159001] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #10\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n whitetop\r\n \r\n
    whitetop is offline\r\n\r\n \r\n
    \r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2016
    \r\n \r\n \r\n
    Posts
    58
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n alternator put on but wrong belt was given to me, 12.99 down the drain. drivers window not working so a relay fix needed, lacking power (even a 1L punto passed me at 40mph) speedo it around 5-8mph short of real speed, fuel needle not showing real amount in tank, clutch is spongy, & steering will not make its mind up on being lite or hard to steer, (all over the dam road).
    \n
    \nPhoned up my nearest MG center and soon as i said the fuel and speedo i was told to bring it in, so hope its not a big cost as this dam 300$ worth of car cost 700$ to buy and 1200$ to fix and now i\'m still paying for it to be fixed.\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[159017] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #11\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n JOHNDQ\r\n \r\n
    JOHNDQ is offline\r\n\r\n \r\n
    \r\n \r\n Senior Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n \r\n JOHNDQ\'s Avatar\r\n \r\n
    \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2013
    \r\n
    Location
    Bedford
    \r\n \r\n
    Posts
    994
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Relay for window is another common problem and the BCU is a plan to get out in the ZR also the relay is only a few £\'s needs to be de-soldered from the circuit board\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; pd[159033] = '\r\n
  • \r\n\r\n\r\n
    \r\n \r\n \r\n \r\n #12\r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n \r\n
    \r\n whitetop\r\n \r\n
    whitetop is offline\r\n\r\n \r\n
    \r\n \r\n Member\r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    Join Date
    Aug 2016
    \r\n \r\n \r\n
    Posts
    58
    \r\n
    \r\n\r\n
    \r\n
    Dislike / Like Alerts
    \r\n
    \r\n\r\n
    \r\n\r\n
    \r\n \r\n \r\n \r\n \r\n
    \r\n
    \r\n
    \r\n \r\n \r\n\r\n\r\n \r\n \r\n
    \r\n
    \r\n
    \r\n Well window started working again when i had to pick the wife up from work, but everything else is still going on, lost a load of power on the way back home, rang up the MG dealers and said it could be the o2 sensor or the pre-cat lamba sensor.\r\n
    \r\n
    \r\n\r\n \r\n
    \r\n
    \r\n \r\n
    \r\n
    \r\n
    \r\n
    \r\n -' + '->\r\n
    \r\n \r\n \r\n \r\n \r\n \r\n Reply With Quote Reply With Quote \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n\r\n \r\n \r\n\r\n \r\n \r\n \r\n \r\n \r\n \r\n -' + '->\r\n
    \r\n
    \r\n
    \r\n
  • \r\n'; // next/previous post info pn[158746] = "159033,158778"; pn[0] = ",158746"; pn[158778] = "158746,158794"; pn[158794] = "158778,158834"; pn[158834] = "158794,158865"; pn[158865] = "158834,158953"; pn[158953] = "158865,158961"; pn[158961] = "158953,158969"; pn[158969] = "158961,158977"; pn[158977] = "158969,159001"; pn[159001] = "158977,159017"; pn[159017] = "159001,159033"; pn[159033] = "159017,158746"; // cached usernames pu[0] = guestphrase; pu[15530] = "whitetop"; pu[1425] = "JOHNDQ"; // -->

    Threaded View

    1. #11
      Senior Member
      Join Date
      Aug 2013
      Location
      Bedford
      Posts
      994
      Dislike / Like Alerts
      Relay for window is another common problem and the BCU is a plan to get out in the ZR also the relay is only a few £'s needs to be de-soldered from the circuit board

     

     

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •  
    Powered by vBulletin® Version 4.2.1
    Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.
    Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
    Image resizer by SevenSkins
    vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
    Copyright © MGZROwnersClub.co.uk
    All times are GMT +1. The time now is 20:45.