Enginer temp thermostat issue
Results 1 to 3 of 3
  1. #1
    *Newbie*
    Join Date
    Feb 2017
    Posts
    2
    Dislike / Like Alerts

    Engine temp thermostat issue

    So our ZR 1.4 decided to not want to heat up when on the dualer but in town the gauge would creep up slowly then it would go back down again once up to any sort of speed again.

    Sounds like thermostat so as we had only had it a week I spoke to the garage and they agreed to take it back as they had apparently just replaced the thermostat.

    Picked it back up from them and still the same issue. Anything else it could be? Part of me wonders if the garage is just saying they put another one in and didn't really do it.
    Last edited by Shoe2190; 03-04-17 at 13:59.

  2. Remove Advertisements
    MGZR Owners Club
    Advertisements
     

  3. #2
    Member
    Join Date
    Aug 2016
    Posts
    71
    Dislike / Like Alerts
    I would take it to another place mate,

    Mine gets stuck now and then and once the car is warm i tap the top of the clocks and the needle unsticks. if this don't work i would get it to a real garage and tell them everything.

  4. #3
    Senior Member
    Join Date
    Aug 2013
    Location
    Bedford
    Posts
    1,008
    Dislike / Like Alerts
    Definitely sounds like a thermostat fault have you thought about retrofitting a PRT thermostat kit to the car if you plan on keeping it as will help to avoid HGF due to heat build up

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBulletin® Version 4.2.1
Copyright © 2017 vBulletin Solutions, Inc. All rights reserved.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Image resizer by SevenSkins
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © MGZROwnersClub.co.uk
All times are GMT +1. The time now is 12:00.